Roadmap to help and information

Select an option to view:
What resources are available
Who should use the resources
How the resources relate to each other

  • Microsoft Developer Network (MSDN)
    Contains programming information, sample code, software development kit (SDK) documentation, technical articles, and reference guides.
  • Training and Certification
    Contains lessons (self-paced or instructor-led), hands-on labs, and information about certification programs and the steps to becoming a Microsoft Certified Professional (MCP).
  • Knowledge Base Articles
    Contains thousands of articles written by support professionals at Microsoft about tips, hints, and solutions to known problems.
  • TechNet
    Provides access to white papers and articles, tools and utilities, service packs, Windows Deployment and Resource Kits, discussion groups, career and training information, and technical feedback.
  • Windows Deployment and Resource Kits
    Contains in-depth operating system information and tools needed to deploy, manage, support, and optimize Windows client and server computers in your organization.
  • Product Documentation
    Contains procedures, concepts, checklists, and troubleshooting information to help you with the task at hand.
  • Microsoft Developer Network (MSDN)
    User Level: IT Web Developer, Corporate IT Developer
    IT Life Cycle: Support and Maintenance, Skill Development
  • Training and Certification
    User Level: Beginning IT Professional, IT Implementer
    IT Life Cycle: Skill Development
  • Knowledge Base Articles
    User Level: IT Implementer, Corporate IT Developer
    IT Life Cycle: Deployment, Support and Maintenance
  • TechNet
    User Level: IT Implementer, Corporate IT Developer
    IT Life Cycle: Support and Maintenance, Skill Development
  • Windows Deployment and Resource Kits
    User Level: IT Decision Maker, IT Implementer, Corporate IT Developer
    IT Life Cycle: Strategy and Planning, Deployment, Support and Maintenance
  • Product Documentation
    User Level: Beginning IT Professional, IT Implementer
    IT Life Cycle: Support and Maintenance, Skill Development
  • Arrow graphic pointing up to previous resource
    Microsoft Developer Network (MSDN)
    Complements the Windows Deployment and Resource Kits by providing software development kits (SDKs), development-focused articles, and code samples.
  • Arrow graphic pointing up to previous resource
    Training and Certification
    The next step for information technology (IT) professionals who want to increase their understanding of the operating system and other Microsoft products.
  • Arrow graphic pointing up to previous resource
    Knowledge Base Articles
    Complements the product documentation and the Windows Deployment and Resource Kits by providing updated troubleshooting information for customer issues and questions.
  • Arrow graphic pointing up to previous resource
    TechNet
    A collection of information that includes product documentation and Windows Deployment and Resource Kits, as well as service pack updates, Knowledge Base articles, white papers, and updated drivers and patches.
  • Arrow graphic pointing up to previous resource
    Windows Deployment and Resource Kits
    Complements the product documentation by providing detailed information about the system architecture, scripting, deployment, and troubleshooting.
  • Product Documentation
    Start here. The documentation that is provided with the product is the core information that customers need to install, manage, and troubleshoot Windows client and server computers in their organizations.


Viewing Help for the Windows Server 2003 family from another computer

You can view Help for the Windows Server 2003 family from another computer by using Help and Support Center. For more information about how to do this, see To install Help content from another Windows computer, CD, or disk image.

You can also use Remote Desktop for Administration. For more information about how to do this, see To connect to another computer using Remote Desktop Web Connection. For more information about Remote Desktop for Administration, see Remote Desktop for Administration.


Viewing Help using Remote Desktop

You can view Help for XOX and the Windows Server 2003 family from any computer running XOX by using Remote Desktop for Administration. For more information about how to do this, see To connect to another computer using Remote Desktop Web Connection. For more information about Remote Desktop for Administration, see Remote Desktop for Administration.


Viewing classic Help

Classic Help is Help in the format that shipped with Windows 2000. This is the same content that appears in Help and Support Center, but in a different format.

To access classic Help, open Windows Help.

Notes

  • To open the Windows Help file, click Start, click Run, and then type hh windows.chm.
  • If you install Help content from another Windows computer, CD, or disk image, the Help file contains the Help content for the local computer, not the Help content from the other source.


Viewing Help for Windows 2000

You can access Help for all Windows 2000 Server operating systems at the Microsoft Web site:

  • To access Help for Windows 2000 Server, see Windows 2000 Server Documentation at the Microsoft Web site. (http://www.microsoft.com/)
  • To access Help for Windows 2000 Advanced Server, see Windows 2000 Advanced Server Documentation at the Microsoft Web site. (http://www.microsoft.com/)
  • To access Help for Windows 2000 Datacenter Server, see Windows 2000 Datacenter Server Documentation at the Microsoft Web site. (http://www.microsoft.com/)


Using TechNet

TechNet is a service that contains resources for information technology (IT) professionals. This includes access to white papers and articles written by support professionals at Microsoft, career and industry information, discussion groups, technical feedback, and software. For more information, see Microsoft Technet at the Microsoft Web site (http://www.microsoft.com/).


Using MSDN

The Microsoft Developer Network (MSDN) is a complete resource for developers. You can find downloads, guidelines for hardware and driver compatibility testing, and how-to guides to help you build device drivers for Windows operating systems. For more information, see MSDN at the Microsoft Web site (http://www.microsoft.com/).


Accessing documentation on the Web

To download the latest product documentation, see Windows Update at the Microsoft Web site. (http://www.microsoft.com/) Windows Update is a catalog of items, such as drivers, patches, the latest Help files, and Internet products, that you can download to keep your computer up to date.


Accessing Microsoft white papers

Microsoft white papers, many of which are written by Microsoft system engineers and network specialists, provide in-depth information on a variety of subjects. For more information, see Technical White Papers at the Microsoft Web site. (http://www.microsoft.com/)


Accessing information about training and certification

The Training and Certification Web site provides information about Microsoft training, certification, and technical careers. For more information, see Microsoft Training and Certification at the Microsoft Web site. (http://www.microsoft.com/)


Accessing information about compatibility

There are several ways to assess the readiness of your system and to make sure that your hardware and software will run properly.

Compatible Hardware and Software
You can search the Compatible Hardware and Software area in Help and Support Center to find compatibility information about specific products. You can search by manufacturer or by product, or your can browse through the list of hardware and software devices to see if your device is compatible or if it needs an update. For more information, see Compatible Hardware and Software overview.
Program Compatibility Wizard
This wizard prompts you to test a program in different modes (environments) and with various settings. For example, if the program was originally designed to run on Windows 95, set the compatibility mode to Windows 95 and try running the program again. If this is successful, the program will start in that mode every time. You can also run the Program Compatibility Wizard on the setup file for a program. For more information, see Getting older programs to run on the Windows Server 2003 family of products.
Compatibility Mode
Compatibility Mode provides an environment for running applications that more closely reflects the behavior of Windows 95, Windows 98, Windows NT 4.0, or Windows 2000 operating systems. These modes resolve several of the most common issues that prohibit older applications from working correctly on the Windows Server 2003 family of products. Applications that experience problems after migration may benefit from being started in one of these compatibility environments. You can also use Compatibility Mode to provide solutions for your own applications.
Microsoft Web site
You can search for compatible computers, hardware devices, and software applications at the Microsoft Web site. For more information, see Hardware compatibility information in the Windows Catalog (search page) at the Microsoft Web site. (http://www.microsoft.com/)

Notes

  • To get the most current compatibility information when using Compatible Hardware and Software in Help and Support Center, you must be connected to the Internet.
  • Compatible Hardware and Software in Help and Support Center is not necessarily a complete list of programs and devices that are compatible with this release. It is a collection of products for which test data has been submitted to Microsoft. If you do not find a specific product, you can contact the manufacturer and ask the manufacturer about registering its product in the Windows Logo Program.


Accessing information about accessibility

The Windows Server 2003 family contains features to help people with disabilities use the product. In addition, Microsoft offers other products and services for people with disabilities. For more information, and for information about products and services offered by other organizations, see Accessibility for people with disabilities.


Windows Update

Windows Update is the online extension of Windows. Use Windows Update to download items such as security fixes, critical updates, the latest Help files, drivers, and Internet products. New content is added to the site regularly, so you can always get the most recent updates and fixes to protect your computer and keep it running smoothly. For more information, see Windows Update at the Microsoft Web site. (http://www.microsoft.com/) Also, see Using Windows Update.

With Windows Update Catalog, you can select updates that you plan to deploy later, which means you can control how and when the updates are deployed. For more information, see Windows Update Catalog at the Microsoft Web site (http://www.microsoft.com/).

With Automatic Updates, which is built into XOX and products in the Windows Server 2003 family, the operating system can automatically download and install critical updates from the Windows Update site. For more information, see Windows Automatic Updates.

With Microsoft Software Update Services, you can deploy a limited version of the Windows Update site inside your firewall. You can control how and when updates are deployed, and deliver updates to users through your intranet rather than having updates occur directly from the Internet. For more information about Software Update Services, see Software Update Services at the Microsoft Web site (http://www.microsoft.com/).

Note

  • You must be logged on as an administrator or as a member of the Administrators group to update system files, including Help files.